HandBrake für Mac bauen

Um HandBrake für Mac zu bauen, benötigt man einen Apple Computer mit einem 64-bit Intel Prozessor, auf dem mindestens OS X 10.11.5 El Capitan läuft, und folgende Abhängigkeiten.

Zusätzliche Abhängigkeiten (können mit dem mitgelieferten Script gebaut werden):

Installiere Xcode1 und öffne es einmal. Bestätige alle Fragen bezüglich der Installation zusätzlicher Werkzeuge. Du kannst Xcode nachdem es vollständig geladen ist wieder beenden.

Installiere Kommandozeilen Werkzeuge für Xcode2.

xcode-select --install

Klone das HandBrake Repository.

git clone https://github.com/HandBrake/HandBrake.git && cd HandBrake

Liste die verfügbaren Tags in der HandBrake 1.1.x Release Serie und checke den aktuellsten aus.

git tag --list | grep ^1\.1\.
git checkout refs/tags/$(git tag -l | grep -E '^1\.1\.[0-9]+$' | tail -n 1)

Du kannst die zusätzlichen Abhängigkeiten mit dem mitgelieferten Script bauen und installieren. Wenn du möchtest, kannst du den Ausgabepfad abändern.

scripts/mac-toolchain-build /usr/local

Dieser Prozess dauert ein paar Minuten. Falls es notwendig ist, wird dir das Script Anweisungen geben, wie du den Ort der erstellten Binaries zu dem Umgebungspfad3 hinzufügst. Mache dies jetzt.

Baue HandBrake. Um nur das Kommandozeileninterface zu bauen, deaktivere die grafische Benutzeroberfläche indem du --disable-xcode anhängst.

./configure --launch-jobs=$(sysctl -n hw.ncpu) --launch

Wenn der Prozess abgeschlossen ist, findest du HandBrakeCLI in dem build/xroot Ordner. Falls außerdem die grafische Oberfläche aktiviert ist, findest du HandBrake.app in dem Verzeichnis.

Installiere HandBrake (optional).

sudo make --directory=build install

Um neu zu starten, lösche einfach den build Ordner.

rm -rf build

  1. Stelle sicher, dass Xcode unter /Applications/Xcode.app installiert ist. Wenn ein Xcode Beta Release installiert ist, musst du eventuell Xcode-beta.app in Xcode.app umbenennen.

  2. Wenn du die Kommandowerkzeuge für Xcode mit dem package installer installierst (anstatt xcode-select --install), achte darauf das Paket zu installieren das zu deiner installierten Xcode Version passt. Ein Unterschied zwischen der Versionen von Xcode und der Kommandozeilenwerkzeuge kann Probleme verursachen.

  3. /usr/local/bin is included in the system’s PATH by default. It is not necessary to add it to your environment’s PATH when installing the additional dependencies to /usr/local.