Multiple encodes using the Queue

Encoding videos takes time, and can use a lot of your computer’s computational power.

Luckily, you can set up multiple encodes at once by adding them to HandBrake’s Queue.

Adding encodes to the Queue

Begin by opening a Source, selecting a Title, and selecting a Preset. Then select the Add to Queue button on the toolbar.

Adding an encode to the Queue
Select the Add to Queue button on the toolbar to add your encode to the queue.
HandBrake toolbar on Windows
Select the Add to Queue button on the toolbar to add your encode to the queue.

Select the Show Queue button on the toolbar to see the queued encodes, or Jobs.

Opening the Queue window
Select the Show Queue button on the toolbar to open the Queue window.
Queue window on Mac
The Queue window lists pending Jobs.
HandBrake toolbar on Windows
Select the Show Queue button on the toolbar to open the Queue window.
Queue window on Windows
The Queue window lists pending Jobs.

You may open additional Sources and add them to the Queue in the same manner.

Adding multiple encodes simultaneously

When using the Queue, you may find it beneficial to create multiple Jobs at one time.

On Mac, first open the Preferences window using the HandBrake menu. In the General section, ensure that the Automatically name output files setting is selected and Title is part of the Format field.

Opening the Preferences window on Mac
Open the Preferences window using the HandBrake menu.
Selecting the Automatically name output files setting
Select Automatically name output files to ensure unique file names when adding multiple Titles to the Queue.

This ensures that each of your Jobs will be given a unique file name, and not overwrite each other.

On Windows, first open the Preferences window using the Tools menu. In the Output Files section, ensure that the Automatically name output files setting is selected. Set a Default Path (where your new videos will be created) and make sure Title is part of the File Format field.

Opening the Preferences window on Windows
Open the Preferences window using the Tools menu.
Selecting the Automatically name output files setting
Set up Automatic File Naming to ensure unique file names when adding multiple Titles to the Queue.

This ensures that each of your Jobs will be given a unique file name, and not overwrite each other.

If your Source is a Blu-ray, DVD, or other disc or disc-like format with multiple Titles, you may open it with HandBrake and add multiple Titles to the Queue simultaneously.

Additionally, you may open a folder of multiple single-Title videos (excluding discs and disc-like formats) as one virtual Source with multiple Titles using the Open Source dialog, and then add multiple Titles to the Queue1.

Opening a folder containing multiple video Sources
The Open Source dialog allows you to select a folder containing multiple video files.
Selecting a Title
The Title control lets you select which video clip you want to use.

On Linux, select Add Multiple from the Queue menu, then select the Titles you wish to encode using the presented dialog. Be sure to give each a unique file name.

On Mac, select Add Titles to Queue... from the File menu, then select the Titles you wish to encode using the presented dialog.

Add Titles to Queue menu item
Select Add Titles to Queue… from the File menu to open a selection dialog.
Selecting multiple Titles to add to the Queue
Select the Titles you wish to encode from the Add Titles to Queue dialog.

On Windows, select All Selection to Queue from the Queue menu to add all Titles.

You may open additional Sources and add them to the Queue in the same manner.

Editing Jobs

To make changes to Jobs in the Queue, first open the Queue window by selecting the Show Queue button on the toolbar.

Opening the Queue window
Select the Show Queue button on the toolbar to open the Queue window.
HandBrake toolbar on Windows
Select the Show Queue button on the toolbar to open the Queue window.

To remove a Job, select the button next to the unwanted Job.

On Linux, if you want to make changes to a Job already in the Queue, select the Job and then select Edit. Editing a Job opens the Source in HandBrake’s main window and removes the Job from the Queue.

On Mac, if you want to make changes to a Job already in the Queue, control- or right-click on the Job and select Edit. Editing a Job opens the Source in HandBrake’s main window and removes the Job from the Queue.

Editing an encode Job on Mac
Control- or right-click the Job and select Edit to make changes.

On Windows, if you want to make changes to a Job already in the Queue, select the edit button next to the Job. Editing a Job opens the Source in HandBrake’s main window and removes the Job from the Queue.

Editing an encode Job on Windows
Select the edit button, which looks like a sheet of paper, to make changes to a Job.

When you’re finished making changes, again add the encode to the Queue by selecting the Add to Queue button on the toolbar.

Adding an encode to the Queue
Select the Add to Queue button on the toolbar to add your encode to the queue.
HandBrake toolbar on Windows
Select the Add to Queue button on the toolbar to add your encode to the queue.

Starting the Queue

When ready, select the Start button on theQueue window or the Start Queue button on the main window to begin encoding the Jobs in the Queue.

Starting the Queue
The Start Queue button begins encoding the Jobs in the Queue.

  1. When opening multiple videos in a folder, HandBrake ignores any additional folders inside. Make sure the videos you wish to open are at the top level of the selected folder.